cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

iOS: Trouble Casting to Echo Dot

rarcher
Local Performer

When I try to cast Pandora music from an iPhone to my Echo Dot, the only option is Chromecast.  I am able to play Pandora music to the dot via voice command.  The Pandora app on my iPhone shows "Linked with Alexa".  All devices are on the same wifi network. I am using ios 14.4.2.   The dot is 2nd generation.  This feature used to work in the recent past and I fear that I may have mistakenly changed a setting, but can't find what or where to change it. 

mod edit: changed title for clarity

Labels (1)
1 Solution

Accepted Solutions

TannerPandora
Moderator
Moderator

Hi @rarcher!

Just to clarify your post, the Chromcast option on your iPhone is no longer casting to your Echo Dot? Or does it connect, but no music plays? Do you receive any type of error message? If so, what does it say?

Can you do me a favor and share a screenshot(s) of what you see when you try and cast?

In the meantime, can you confirm if have Local Network is enabled in your Phone settings. You can do this by tapping Settings for your iPhone > Scroll down until you see the Pandora app > Confirm Local Network is enabled.

Local Network.png

 

 

 

 

 

 

 

 

 

(The image above shows Local Network disabled)

Tanner | Community Moderator

- Let's share music in the Playlist Swap

View solution in original post

3 Replies

AlyssaPandora
Moderator
Moderator

Hi there, @rarcher. 👋

Thanks so much for letting us know about this. Please try the following steps:

  • Check to see if there are any updates available for your Alexa and Pandora apps. Update both as necessary.
  • Restart your Alexa device by unplugging the power source and plugging it back in.

++

Let's also try relinking Pandora on Amazon Alexa from your iPhone device:

  1. Tap Profile > Settings (the gear icon in the top right) > Link with Alexa.
  2. When prompted to listen with Alexa, select Connect Now.
  3. You'll be taken to the Alexa app to select Link and to enable the Pandora skill. (If you do not have the Alexa app installed you will need to enter your Amazon account login and password first).
  4. Finish by selecting Got it!
  5. Return to the Music settings to set Pandora as your Default Music Library and Default Station.

To group a set of Alexa-enabled devices together, follow these instructions on Amazon's help site.

Let me know how it goes. 🎧

 

Alyssa | Community Moderator

Let's talk music in Community Chat

0 Kudos

rarcher
Local Performer

When I try to complete step 1, screen says "Linked with Alexa", but am unable to cast to echo dot.  The dot will play music from Pandora when I use a voice command.  Any other suggestions?

0 Kudos

TannerPandora
Moderator
Moderator

Hi @rarcher!

Just to clarify your post, the Chromcast option on your iPhone is no longer casting to your Echo Dot? Or does it connect, but no music plays? Do you receive any type of error message? If so, what does it say?

Can you do me a favor and share a screenshot(s) of what you see when you try and cast?

In the meantime, can you confirm if have Local Network is enabled in your Phone settings. You can do this by tapping Settings for your iPhone > Scroll down until you see the Pandora app > Confirm Local Network is enabled.

Local Network.png

 

 

 

 

 

 

 

 

 

(The image above shows Local Network disabled)

Tanner | Community Moderator

- Let's share music in the Playlist Swap

View solution in original post