cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Sonos - "Unable to play Pandora - access is denied"

josebe
Opening Act

I am having the same issue.  Have 16 Sonos devices - six Play 5's, ten Play 3's and a connect AMP.  I keep having to reauthorize Pandora every day.  This never happened before until the past two weeks where I have noticed every single day.  I reported the issue to Sonos and sent them a diagnostic.  My setup is perfect.  once I reauthorize Pandora through the Sonos app I am fine.  SONOS techs passed the buck to Pandora as they see no issue on their side.  I use the free Pandora.

Tanner.  I saw this solution posted in the Sonos community forum site and on a follow up it did not address or solve the issue.  

Moderator Edit: Changing title for clarity

Labels (2)
50 Replies

josebe
Opening Act
Did you have to add the stations back in by doing that? After adding Pandora back to sonos? Just wonder if the stations settings will be lost.

Sent from my iPhone
0 Kudos

ptcurzon
Local Performer

No, I still have all of my Pandora stations. Works as expected. 

0 Kudos

josebe
Opening Act
Perfect. I’ll try it myself tomorrow and see how it goes. Thanks!

Sent from my iPhone
0 Kudos

Raweber62
Local Performer
Just reauthorized and Pandora worked.  I don't think I had to do this before. It's just been happening within the last couple weeks.
0 Kudos

JFCA
Local Performer

I have to reauthorize Pandora EVERY time I try to play a station from the Sonos app. Very annoying!

FWIW, I have a paid Pandora subscription and only starting experiencing this a day or two ago.

0 Kudos

josebe
Opening Act
Hi. This is working now I removed Pandora service from Sonos app and added it again. I have not needed to reauthorize Pandora in two days.

Seems to work fine now.

😁😁😁😁😁

Sent from my iPhone

digitaldan
Local Performer

I have to admit i didn't try removing the app at first as i thought i read that did not work for someone else, but low and behold it did work, thanks!

0 Kudos

josebe
Opening Act
I was not sure if it would work as well but it did. 😁😁😁



Sent from my iPhone
0 Kudos

SDL1
Local Performer

How do I re authorize Pandora?

 

0 Kudos

josebe
Opening Act

In Sonos app.  Go to settings.  Then services and voice.  Select Pandora then reauthorize.  Best option to avoid doing this is to remove the Pandora service from Sonos app then add it back up.  This solved the problem for me. 

theodoremeyer
Local Performer

How do you reauthorize Pandora through the Sonos app?

0 Kudos

josebe
Opening Act

Hi.  In Sonos app tap settings.  Tap services and voice. Tap Pandora then tap reauthorize.   

in order to avoid doing this every day you are better off by removing the Pandora service in the Sonos app then adding the service again. 

best of luck

0 Kudos

jwhdesigns
Local Performer

I'm having the same issue, receiving the message that someone else is listening AND having to reauthorization Sonos after every song!  I've change my password and upgraded from Plus to Premium and nothing is working. Getting ready to cancel-- help.

0 Kudos

josebe
Opening Act

Best bet is to follow the solution I posted in this thread before.  Remove your Pandora account from Sonos app then add it again.  This solved the issue s I had before. 

best of luck 

0 Kudos

Mary8
Local Performer

My husband and I are both receiving access denied on our mobile devices.  He has an android and I have an iphone. We are both using the Sonos app on our phones which controls the home music.  Does anyone know what the problem might be?

Mary8
Local Performer

I'm having the exact same problem! It just started today.  My husband uses and android and I use an i-phone to connect to the Sonos app which controls our Pandora house music.  Any idea what the problem might be?

0 Kudos

josebe
Opening Act

Not sure what the issue is.  I have posted the solution that worked for me on this thread.  It comes down to removing the Pandora app from Sonos app and adding it again.  I have not experienced any problems in the past three weeks. 

best of luck

0 Kudos

LoocieB
Local Performer

Having the same issue today. Can play on my computer but not on my Sonos system. Got it to play for one hour but then it quit. Reloaded Pandora on Sonos which helped the problem for that one hour but same problem came back.

0 Kudos

TannerPandora
Moderator
Moderator

Pandora Update 9/22/21: Hi everyone! Thanks for posting your experience. We're working closely with Sonos to help resolve this. 

Sonos has requested some additional information to help in their investigation. If you're new to this thread, please include the following info with your post:

  • What device are you using with your Sonos? (iOS, Android, Mac desktop or Windows desktop)
  • Do you use a mesh network?
  • The Sonos diagnostic number
    • When you experience this again, please use the steps outlined here to submit a diagnostic to Sonos. Then write back with the confirmation number you received.

Thanks for your understanding and patience in the meantime. 

 

 

Tanner | Community Moderator

- Let's share music in the Playlist Swap

View solution in original post

0 Kudos

sreedy71
Underground

This started for me this morning around 8am on 09/21/2021. I have tried a few times to remove Pandora from Sonos on my phone and laptop and then add it back in. Pandora says All done. But Sonos still gives the error. Trying again to give you the information you need. At one point on the Pandora side it said maintenance was being done so I didn't try again until now.

Google Pixel 5 Android Version 11 Confirmation number 939206541.

Sonos S2 Version 13.2.2 Build: 64320120

Dell Laptop Windows 10 Interestingly didn't get the error this time. Still sent in diagnostics for comparison. Confirmation number 1464570659.

Sonos S2 Version 13.2 Build: 64319080

Do we need to also notify Sonos or are you doing that as a parent case?

Now that I have it playing via the laptop, the phone shows it as playing.  I stopped it via the phone (with laptop app still active) and then started it and it's playing. Tried it by stopping via phone, closing app, then starting via phone and it's working. Changes station for good measure. It's working now.

LOL I'm wondering if it got fixed as I was doing all of this and typing it out.

 

0 Kudos