Showing results for 
Show  only  | Search instead for 
Did you mean: 

Roku: Enabling the Explicit Filter

Local Performer

How do you turn off Explicit Content because I cant have it playing 

Moderator Edit: Changing title for clarity

Labels (1)
0 Kudos
1 Reply


Hi @Beau2 

Welcome to community!

A closer look at your account shows you're listening from a Roku.

You can restrict Pandora from playing songs or ads with explicit content on your Roku by pressing the Up Arrow on your remote to display the Menu at top of the screen. Click the icon (initial or picture) in the top right corner of the page, and then select Settings. You'll see the options for Explicit Content under Content Settings.*

You will be prompted to input your current Pandora password to save this setting.

Please note, the explicit filter is only applied to stations and will not filter on-demand content such as albums, songs or playlists. Additionally, the filter will be applied to all devices associated with your Pandora account.

*To ensure you open the main Pandora app (and not our voice-enabled lightweight app), open Pandora from the menu of your Roku, not via voice command.

Tanner | Community Moderator

> Follow us on Twitter

0 Kudos