cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SDL "Waiting for Connection" 'feature'

WilKo
Local Performer

Since the recent Pandora for Android update, the app is attempting to connect via the Smart Device Link API, and it is doing so perpetually.  This had become truly annoying and I've had remove the app when not using the service.

Please remove this 'feature' such that it is clearly arbitrarily seeking an SDL supported resource.

Labels (1)
1 Solution

Accepted Solutions

AlyssaPandora
Moderator
Moderator

Hey there, @WilKo. 👋

Thanks so much for sharing your experience. I completely understand how frustrating this must be. Other listeners have reached out to our support team via email recently to report this. Our engineering team is currently investigating.

If this happens in your vehicle:

Pandora is required to notify you when the app is ready to connect with your vehicle, but is not able to distinguish between vehicles and other Bluetooth devices. As a result, you will see that notification whenever you connect to any Bluetooth device. If you'd like to remove the notification that Pandora is ready to connect with your car, you'll need to disable the Launch from car setting.

To do that:

  • Open Pandora.
  • Tap the Profile tab and then the Settings gear in the top right corner.
  • Select Advanced.
  • Under Bluetooth for devices remove the checkmark next to Launch from car.

Keep in mind that if you disable the Launch from car feature, you'll have to launch Pandora on your phone before you connect your phone to your car via USB or Bluetooth. Otherwise, it won't connect properly.

++

Disabling All Notifications:

If you continue to have trouble and are still unable to hide the notification by long pressing and toggling the switch to OFF, please try the following steps from the Android settings to disable all notifications: 

  • Open Settings
  • Go to Apps
  • Scroll to find and select Pandora.
  • Tap “Force Stop,” then “Disable”
  • Tap Notifications, and disable all options therein.

++

Reporting this Issue:

In the meantime, we do have an internal ticket open with our engineering team. If you don't mind, I'd like to share your information with them while they continue to look into this.

  • Model:
  • Carrier:
  • Android version (Settings > About Phone):
  • Pandora version (Go to Profile, then select Settings. Scroll to the bottom of the screen for the version number):
  • Are you connected to Wi-Fi or cellular data when this is happening?

I look forward to hearing back! 🎧

Alyssa | Community Moderator

Let's talk music in Community Chat

View solution in original post

0 Kudos
14 Replies

AlyssaPandora
Moderator
Moderator

Hey there, @WilKo. 👋

Thanks so much for sharing your experience. I completely understand how frustrating this must be. Other listeners have reached out to our support team via email recently to report this. Our engineering team is currently investigating.

If this happens in your vehicle:

Pandora is required to notify you when the app is ready to connect with your vehicle, but is not able to distinguish between vehicles and other Bluetooth devices. As a result, you will see that notification whenever you connect to any Bluetooth device. If you'd like to remove the notification that Pandora is ready to connect with your car, you'll need to disable the Launch from car setting.

To do that:

  • Open Pandora.
  • Tap the Profile tab and then the Settings gear in the top right corner.
  • Select Advanced.
  • Under Bluetooth for devices remove the checkmark next to Launch from car.

Keep in mind that if you disable the Launch from car feature, you'll have to launch Pandora on your phone before you connect your phone to your car via USB or Bluetooth. Otherwise, it won't connect properly.

++

Disabling All Notifications:

If you continue to have trouble and are still unable to hide the notification by long pressing and toggling the switch to OFF, please try the following steps from the Android settings to disable all notifications: 

  • Open Settings
  • Go to Apps
  • Scroll to find and select Pandora.
  • Tap “Force Stop,” then “Disable”
  • Tap Notifications, and disable all options therein.

++

Reporting this Issue:

In the meantime, we do have an internal ticket open with our engineering team. If you don't mind, I'd like to share your information with them while they continue to look into this.

  • Model:
  • Carrier:
  • Android version (Settings > About Phone):
  • Pandora version (Go to Profile, then select Settings. Scroll to the bottom of the screen for the version number):
  • Are you connected to Wi-Fi or cellular data when this is happening?

I look forward to hearing back! 🎧

Alyssa | Community Moderator

Let's talk music in Community Chat

View solution in original post

0 Kudos

akraut
Local Performer

I am also experiencing this issue. Disabling "Launch from Car" does not affect SmartDeviceLink at all. Disabling all notifications is the only way to stop the pop-up from occurring. However that does not remedy the issue where Pandora SmartDeviceLink is toggling bluetooth on and off, presumably in an attempt to reconnect. This causes issues with any bluetooth based smart devices as well as when listening to music through bluetooth headphones.

  • Model: Motorola Z4
  • Carrier: Verizon
  • Android version: 10
  • Pandora version: ANDROID-TUNER 2009.2RC8
  • Wifi or Cellular: This seems to make no difference. It happens on both connections
0 Kudos

TannerPandora
Moderator
Moderator

Hi @akraut! Thanks for posting your experience. 

I've included the provided info (thanks for sharing! 👍🏻) on our ticket for this. Our engineering team is working on it. 

Keep and eye out on this thread, we'll be making updates here as they are made available to us. 

Thanks for your patience in the meantime. 

Tanner | Community Moderator

Let's share music in the Playlist Swap

0 Kudos

WilKo
Local Performer

I'm happy to share the information you've requested:

Model: LG V30

Carrier: Verizon

Android version: 9

Pandora version: 2009.2RC8

I am primarily connected to WiFi when using Pandora.

0 Kudos

TannerPandora
Moderator
Moderator

Thanks @WilKo! I've added your info to our ticket. 

Stay tuned for updates in this thread. Thanks for your continued patience! 👍🏻

Tanner | Community Moderator

Let's share music in the Playlist Swap

0 Kudos

KHolce
Local Performer

I see this thread is older. This just happened to me.  The Launch from car option was already off.  I was able to long press the notification and toggle to off.

Phone SM N960U - Samsung Note 9

Carrier: Verizon

Android version: Version 10 patch 12/1/20

I have WiFi and data connected.

0 Kudos

TannerPandora
Moderator
Moderator

Hi @KHolce! Thanks for posting your experience. 

We are aware of this issue and are working on it. I've passed your info along to our engineers.

Sorry for any inconvenience!

Tanner | Community Moderator

Let's share music in the Playlist Swap

0 Kudos

HansSchulze
Underground

LG V35 on Google Fi, Android 9, Pandora 2011.1 Android Tuner.

Tesla 3 has been inconsistently able to play pandora without using phone voice command to start it.

Cant SDL check the BT devices for SDL without annoying us?  Who wrote this dumb api?  And it seems that only Toyota Mitsubishi and two others support it.  Thats annoying half your user base.

Shouldn't we have a list of cars to connect to in the app?  BT opens my car doors...

asilisa
Local Performer

I'm, also, having this problem!  What makes me crazy is I uninstalled Pandora and unpaired my vehicle from my phone and I'm still getting SDL icon on my lock screen.  WHY? 

  • Model:  LG V30
  • Carrier:  TMobile
  • Android version (Settings > About Phone):  9
  • Pandora version (Go to Profile, then select Settings. Scroll to the bottom of the screen for the version number):  pandora plus
  • Are you connected to Wi-Fi or cellular data when this is happening?  both
0 Kudos

Khall63
Local Performer

How do I get rid of Smart Device Link waiting to connect? I have a LG G7 thinq 

0 Kudos

alankchan
Local Performer

Please add me to the ticket:

  • Model: Samsung Galaxy S10 Plus
  • Carrier: Verizon
  • Android version (Settings > About Phone): 11
  • Pandora version (Go to Profile, then select Settings. Scroll to the bottom of the screen for the version number): 2101.1
  • Are you connected to Wi-Fi or cellular data when this is happening? cellular data
0 Kudos

AlyssaPandora
Moderator
Moderator

Hi there, @Khall63. 👋

I moved your post over to this existing thread to keep the community space organized:

Please check out the accepted solution for this thread here.

If you continue to have trouble with this, please let us know. 

++

Hi, @alankchan. 👋

Thanks so much for posting your device details. I will be sure to report this over to our engineering team on your behalf. 🎧

Alyssa | Community Moderator

Let's talk music in Community Chat

0 Kudos

Zaman
Local Performer

I have this same issues, please help us fix it

  • Sony xperia:
  • TMobile
  • Android version 10
  • Pandora version 2101.1
  • cellular
0 Kudos

Debbie54
Local Performer

I'm also having these same issues.

Model: Samsung A51 Carrier: Verizon 

Pandora version: 2103.1(Android-tuner 21031004

 

 

 

 

 

0 Kudos